Se detecta vulnerabilidad en RedHat a Ataques de Inyección de Comandos



Un investigador de seguridad de Google descubrió una vulnerabilidad crítica en el cliente DHCP, que permite inyección de comandos de manera remota, tanto en la distribución de Redhat y sus derivados como Fedora.

La vulnerabilidad fue identificada como CVE-2018-1111 y esta permite inyección remota de comandos con privilegios Root en los sistemas operativos objetivos.

El servicio de DHCP (Dynamic Host Control Protocol) simplifica la administración de IP en los equipos de una red, permitiendo al computador que posea este cliente, lograr obtener una dirección de IP, DNS, puerta de enlace y otros parámetros adicionales de manera automática.

La vulnerabilidad reside en el script de integración de NetworkManager incluido en los paquetes de cliente DHCP que está configurado para obtener la configuración de red utilizando el protocolo DHCP.



Felix Wilhelm, del equipo de seguridad de Google, descubrió que los atacantes con un servidor DHCP malicioso o conectados a la misma red que la víctima, pueden explotar esta falla falsificando las respuestas DHCP, lo que les permite ejecutar comandos arbitrarios con privilegios de administrador en el sistema de la víctima.

Siendo que el detalle de la vulnerabilidad no ha sido publicada, el código de explotación fue publicado, y este es tan corto que fue publicado en un Tweet



Según el aviso de seguridad, Redhat confirma que la vulnerabilidad afecta a versiones Enterprise 6 y 7 y que todos los clientes que utilizan los cliente DHCP estan vulnerables, por tanto soliclitan actualizar el cliente tan pronto como este disponible su actualización.

Fedora tambien lanzo sus actualizaciones para las versiones 26, 27 y 28.