Redistribucion entre RIPv2 y OSPF CISCO




Bueno aca dejo un ejemplo de Redistribucion de rutas entre OSPF y RIP v2

Bueno en simples palabras lo que hacemos aqui es "combinar" los protocolos de enrutamiento para que se logren entender... En cada Circulo esta configurado un protocolo de enrutamiento, esta rip en las puntas y OSPF en el centro.

Comandos
para OSPF:

router ospf 109
redistribute rip subnets

Para Rip

router rip
redistribute ospf 109 match internal external 1 external 2
----------------------------------------------------------------------

dejare parte de los Show running-config
-------------------------------------------------------------------------------
ROUTER 0
Building configuration...

Current configuration : 855 bytes

!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.3.1 255.255.255.252
clock rate 128000
!
interface Serial0/0/1
ip address 192.168.3.5 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 192.168.3.0 0.0.0.3 area 0
network 192.168.3.4 0.0.0.3 area 0
!
router rip
version 2
redistribute ospf 1 match external 2
network 192.168.0.0
!
ip classless

------------------------------------------------------------------------
Router 1

Building configuration...


!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.3.9 255.255.255.252
!
interface Serial0/0/1
ip address 192.168.3.6 255.255.255.252
clock rate 128000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 192.168.3.4 0.0.0.3 area 0
network 192.168.3.8 0.0.0.3 area 0
!
router rip
version 2
redistribute ospf 1 match external 2
network 192.168.1.0
!
ip classless

------------------------------------------------------------------------
Router2

Building configuration...
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.3.9 255.255.255.252
!
interface Serial0/0/1
ip address 192.168.3.6 255.255.255.252
clock rate 128000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 192.168.3.4 0.0.0.3 area 0
network 192.168.3.8 0.0.0.3 area 0
!
router rip
version 2
redistribute ospf 1 match external 2
network 192.168.1.0
!
ip classless


SALUDOS!!!!! Cualquier cosa pregunten....